Unable to submit Requests in service catalog 17.1

Document ID : KB000118826
Last Modified Date : 01/11/2018
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Issue:
Unable to raise request a service and report an issue in USS
Environment:
CA Service Catalog 17.1
Cause:
missing couple of columns in couple of usm tables. 

req_for_uuid usm_request 
req_for_uuid usm2request 
Resolution:
Follow the instructions as below on your DB server to confirm for missing columns

Run the below query: 
"SELECT c.name AS 'ColumnName',t.name AS 'TableName' 
FROM sys.columns c 
JOIN sys.tables t ON c.object_id = t.object_id 
WHERE c.name LIKE '%req_for_uuid%' 
ORDER BY TableName,ColumnName; "
Note if below couple of missing columns in usm tables . 
 
req_for_uuid usm_request 
req_for_uuid usm2request

If yes, Run the below alter queries to correct the data in usm tables - 
 
ALTER TABLE usm_request ADD req_for_uuid BINARY(16) NULL, req_by_uuid BINARY(16) NULL; 

ALTER TABLE usm2request ADD req_for_uuid BINARY(16) NULL, req_by_uuid BINARY(16) NULL;

Test the behavior after recycle of services and clearing translets, web browser cache.