Unable to start up WA Agent after installing 11.3.4 SAP plugin

Document ID : KB000007831
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After installing SAP plugin 11.3.4 on a Linux WA Agent 11.3 SP6, the Agent startup fails with the following errors:

08/14/2017 15:02:41.289 CST+0800 5 main.MainThread.CybSapPluginDriver.runApplication[:85] - CybSapPluginDriver Build 42, Service Pack 4, Maintenance Level 0 starting 

08/14/2017 15:02:41.522 CST+0800 1 main.MainThread.CybAgentDriver.runApplication[:389] - cybermation.library.plugins.CybPluginException: Plugin instantiation failed 

at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(CybPluginManager.java:359) 

at cybermation.agent.plugins.manager.CybPluginManager.loadPlugins(CybPluginManager.java:517) 

at cybermation.agent.CybAgentDriver.runApplication(CybAgentDriver.java:319) 

at cybermation.agent.CybAgentDriver.main(CybAgentDriver.java:454) 

Caused by: java.lang.reflect.InvocationTargetException: null 

at sun.reflect.NativeMethodAccessorImpl.invoke0(Unknown Source) 

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62) 

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) 

at java.lang.reflect.Method.invoke(Method.java:498) 

at cybermation.agent.plugins.manager.CybPluginManager.invokePluginMethod(CybPluginManager.java:347) 

at cybermation.agent.plugins.manager.CybPluginManager.loadPlugins(CybPluginManager.java:517) 

at cybermation.agent.CybAgentDriver.runApplication(CybAgentDriver.java:319) 

at cybermation.agent.CybAgentDriver.main(CybAgentDriver.java:454) 

Caused by: java.lang.ExceptionInInitializerError: JCo initialization failed with java.lang.UnsatisfiedLinkError: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/libsapjco3.so: /opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT/libsapjco3.so: wrong ELF class: ELFCLASS64 (Possible cause: architecture word width mismatch)

 

 

 

Environment:
WA Agent 11.3 SP6, 32-bitSAP plugin 11.3 SP4Linux
Cause:

The 64-bit version of the libsapjco3.so library was installed on the system causing the problem. As the WA Agent installed on the system was 32-bit version, the libsapjco3.so library also has to be 32-bit version. 

 

 

Resolution:

Replace the 64-bit version of the libsapjco3.so library with the 32-bit version in the 

/opt/CA/WorkloadAutomationAE/SystemAgent/WA_AGENT directory.

Additional Information: