Unable to send Emails

Document ID : KB000107565
Last Modified Date : 24/07/2018
Show Technical Document Details
Issue:
We have configured the Our Test Portal server to use our SMTP host as per the documentation.

https://docops.ca.com/ca-api-developer-portal-enhanced-experience/4-2/en/install-configure-and-upgrade/configure-and-use-external-mail-server

The Portal server IP has been added to the SMTP relay allow list.

However we are unable to send any emails.
Environment:
API Portal 4.2
 
Cause:
The problem is the docker stack needs to be recreated after the portal.properties file is modified

<install_dir>/conf/portal.conf

So that the new parameters (new IP address, or server name of the mail server in this case) flow through to the docker containers and their setup.
 
Resolution:

The process to remove the current docker stack and then re-instate it is as follows.  Once rebuilt then the new stack containers have the correct setting for the changed mail server. 

# remove current stack 

docker stack rm portal

watch docket ps   # (until all the containers are closed) 


docker rm $(docker ps -qa)

docker container prune
 

# restart and rerun portal 

systemctl restart docker

cd <portalhome> 

./portal.sh

watch docket ps   # (until all the containers are running)