Unable to send an email using SMTP Mail Action Notification from WebView

Document ID : KB000045798
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem

Unable to send an email using SMTP Mail Action Notification from WebView

Workflow:

1.Login to webview and navigate to Management Tab

2.Click on Elements drop-down and select "New Send SMTP Mail Action"

3.Supply the values for From and To Mail, click on Configure Mail Server Link and give the SMTP Server details.

4.Save the content

5.After clicking on Test Now Button, you receive the below error message : 

   Action "New Send SMTP Mail Action" Contained invalid addresses. Could not send email to: 

Also, the email is not sent

 

Cause

Connecting to a SMTP server with user/password authentication is not supported.

 

Workaround:

1. Stop the Enterprise Manager.

2. Open the EM_HOME/Introscope_Enterprise_Manager.lax file

3. Add the smtpTestingUserId and smtpTestingPassword parameters to the lax.nl.java.option.additional property as follow:

-DsmtpTestingUserId=<user> -DsmtpTestingPassword=<password>

4. Start the Enterprise Manager.

 

NOTE: The password is in clear text, hence this workaround should only be used in testing or non-supported situations until the proper password storage is implemented. 

 

You can open an Enhancement Request for this limitation by placing an idea in CA Communities.

Go to https://communities.ca.com/community/ca-apm 

Log in

Click Actions

Create an idea