Unable to see the Smartstor historical data after upgrading to 10.5

Document ID : KB000099981
Last Modified Date : 04/06/2018
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Issue:
After upgrading to 10.5, I am unable to see the Smartstor historical data
 
Cause:
You could encounter this situation if you are:
 
a) using the Introscope EM Installer:
 
The failures happen when the SmartStor data is stored in an external data directory <External_SmartStor_Home>/data and not the default, <EM_Home>/data. 
There is defect in Introscope EM installer that does not update "introscope.enterprisemanager.smartstor.directory.metadata" and use instead the default value : data/metadata.
At first start after the upgrade, the <EM_Home>/data/metadata directory is initialized incorrectly as empty .
 
This issue is fixed in 10.5.2 and higher versions, see https://docops.ca.com/ca-apm/10-5/en/ca-apm-release-notes
 
b) Performing a manual upgrade:
 
You forget to update the introscope.enterprisemanager.smartstor.directory.metadata property in the EM_HOME/config/IntroscopeEnterpriseManager.properties file.
Resolution:
1. Shut down the Enterprise Manager.

2. Open the IntroscopeEnterpriseManager.properties file.
a. Find the introscope.enterprisemanager.smartstor.directory.metadata property in the Metadata Database Settings section.
b. Set introscope.enterprisemanager.smartstor.directory.metadata to the metadata  directory of the <External_SmartStor_Home>/data/metadata directory.
For example:
introscope.enterprisemanager.smartstor.directory.metadata=<External_SmartStor_Home>/data/metadata
 
3. Rename the <EM_Home>/data directory as <EM_Home>/data_backup.

4. If the <EM_Home>/data/metadata directory exists, rename as <EM_Home>/data/metadata_backup.

5.Start the Enterprise Manager.
The Enterprise Manager upgrades the correct Smartstor metadata
You can now view your historical data