Unable to see Sybase probe after importing. Sybase Probe shows in red after security validation.

Document ID : KB000004449
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Unable  to see the Sybase probe after importing from archive.

Sybase Probe shows in red even after security validation.

Environment:
UIM: 8.31, 8.4, 8.42 and 8.47OS: Sybase probe supported platforms
Cause:

It would happen when Sybase client is not installed on the robot for remote monitoring and not followed the prerequisites.

Resolution:

Need to follow below steps on the machine where you would like to deploy the Sybase probe.

1. Please make sure to install Sybase client.

2. Open the controller configuration (Right click on Controller probe and click on 'Configuration').

3. Under "Setup" tab, select 'Environment' Options.

4. Add the following environment variables.

LD_LIBRARY_PATH: /opt/sybase/ASE-15_0/lib:/opt/sybase/DataAccess64/ODBC/lib:/opt/sybase/DataAccess/ODBC/lib:/opt/sybase/OCS-15_0/lib:/opt/sybase/OCS-15_0/lib3p64:/opt/sybase/OCS-15_0/lib3p:/opt/sybase/ASE-15_0/lib:/opt/sybase/DataAccess64/ODBC/lib:/opt/sybase/DataAccess/ODBC/lib:/opt/sybase/OCS-15_0/lib:/opt/sybase/OCS-15_0/lib3p64:/opt/sybase/OCS-15_0/lib3p

SYBASE: /opt/Sybase

SYBASE_ASE: ASE-15_0

SYBASE_JRE_RTDS: /opt/sybase/shared/SAPJRE-7_1_011_64BIT

SYBASE_OCS: OCS-15_0

SYBASE_WS: WS-15_0

SYBROOT: /opt/sybase

Note: Need to change the paths as per the platform and installation path. (Example given for Windows).

                                sybase.jpg

5. Click on Apply and restart the robot.

6. Then deploy the Sybase probe.

 

Additional Information: