Unable to save tickets due to stdlog error "Violation of PRIMARY KEY constraint 'XPKcall_req'. Cannot insert duplicate key in object..."

Document ID : KB000025549
Last Modified Date : 14/02/2018
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Symptoms:

When try to save requests or tickets in Service Desk, unable to save.

The stdlog recorded "ERROR        sqlclass.c

843 SQL Execute failed: [Microsoft OLE DB Provider for SQL Server] SQL Code=3621 SQL State=01000 The statement has been terminated.; [Microsoft OLE DB Provider for SQL Server] SQL Code=2627 SQL State=23000 Violation of PRIMARY KEY constraint 'XPKcall_req'. Cannot insert duplicate key in object 'call_req'."

 

Environment:

Service Desk 12.x, 14.1

 

Cause:

This problem may arise after one of Service Desk's db_agents needs to re-connect to the database due to a brief loss of the network connection.

 

Resolution:

This should be self resolving.

If not, you may run pdm_key_refresh -r at the command prompt on the primary Service Desk server to refresh the cache of the key values from the database.