Unable to Save a Note on the Timesheet Return screen in PPM

Document ID : KB000009212
Last Modified Date : 23/08/2018
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Issue:

Unable to save Timesheet Notes when Returning a Timesheet on a Popup in CA Project & Portfolio Management (PPM). The 'Save And Return' and the 'Return' buttons are missing. 

Steps to Reproduce:
1. Go to Home -> Timesheets 
2. Click on the Timesheet icon next to an Open Timesheet 
3. Submit the Timesheet for Approval 
4. Log out of PPM 
5. Log back in to PPM as a different user (that has access to approve the timesheet)
6. Go to Home -> Timesheets 
7. Filter for Submitted Timesheets 
8. Click on the Timesheet icon next to the Submitted Timesheet from step 3.
9. Click the 'Return Timesheet' button (This takes you to the 'Add Timesheet Note' page)

Expected Results: The 'Save and Return' and 'Return' buttons are displayed. 
Actual Results: You can enter a note, but cannot save it. The 'Save and Return' and 'Return' buttons are missing. 

Environment:
This issue applies to CA PPM 15.3
Cause:

This is caused by DE37841

Resolution:

This issue is fixed in CA PPM 15.4.

Workaround:

After returning the timesheet, go back into the timesheet, then you can add a note and save it. To do this:

  1. Click on the 'Timesheet' icon next to the returned Timesheet
  2. Click on the 'Timesheets Notes' icon in the upper right hand corner of the timesheet
  3. Add text into the 'Note' text box
  4. Click the 'Add' button (this will save your Note)
  5. Click the 'Return' button to be taken to the previous screen
Additional Information:

Reference the Customer Reported Defect Resolution Policy for CA PPM, CA PPM SaaS and Mobile Time Manager