Unable to run xpssecurity

Document ID : KB000009679
Last Modified Date : 14/02/2018
Show Technical Document Details
Introduction:

Unable to run xpssecurity at policy server side with following error:

C:\Users\Administrator>xpssecurity
'xpssecurity' is not recognized as an internal or external command,
operable program or batch file.

Environment:
Policy server: R12SP3, R12.5, R12.51, R12.52
Instructions:

1. Copy XPSSecurity from the CA SSO (Siteminder) Policy Server installation binaries

Screenshot was captured from r12.52 version.

2. The XPSSecurity need to match the policy server version that you are using and therefore need to copy from the installation binaries that you used. This applied to other version (R12.5, 12.51, 12.52)

R12.52 Windows Server 2008 R2 Enterprise x64 Edition-2016-10-26-10-46-03.png

 

to the <Policy server Install Dir>/bin directory.

R12.52 Windows Server 2008 R2 Enterprise x64 Edition-2016-10-26-10-47-52.png

 

Note: XPSSecurity is found in the installation binaries along with “smreg” and is NOT copied to the \bin directory during installation.