Unable to run the Define Data Source utility during the CMEW patch 5 installation, get the error message "Verify the JDK is installed and in the path, and not the JRE", how do I fix that ?

Document ID : KB000012610
Last Modified Date : 14/02/2018
Show Technical Document Details
Question:

Unable to run the Define Data Source utility during the CMEW patch 5 installation. Get the error message "Verify the JDK is installed and in the path, and not the JRE".  How do I fix that ?

Answer:

JDK needs to be installed on your CMEW server in order to run Define Data Source utility , you can download JDK from oracle,  and make sure JDK is included in the PATH environment variable.

You can check your environment variable by typing this command "echo %PATH%" on your windows command prompt:

CMD.png

In the above example, my JDK "C:\Program Files (x86)\Java\jdk1.6.0\bin" is included in my PATH variable, if JDK is not included in your path, you can update your Path environment variable by going to Control Panel->System and Security->System, choose Advanced System Settings, click Advanced tab, then click Environment variable,  you will find Path as one of the System Variables, click 'edit' to update the Path variable.

Path.png