Unable to run REST Web Service Job in TLS v1.1 or TLS v1.2 mode

Document ID : KB000088089
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure

Unable to run REST Web Service Job in Transport Layer Security (TLS) version 1.1 or TLS version 1.2 mode.

Investigation

The following error is displayed when attempting to use either TLS v1.1 or TLS v1.2 on the WebService Agent running Java 1.7.   However, running the REST Job on the Web Service server using SSL works. 
 
2017-03-26 17:15:34 Connect timeout set to 30 seconds 
2017-03-26 17:15:34 Read timeout set to:60 
2017-03-26 17:15:34 Using connection:CONN.JARVIS.REST@CMM_EBS_JOBS 
2017-03-26 17:15:34 Authentication type:Basic 
2017-03-26 17:15:34 Request:POST https://jarvis-api-master.apps.vpcf-qa.in.spdigital.io/v1/notify/billed?nonce=20170326 
2017-03-26 17:15:34 Request headers:[] 
2017-03-26 17:15:34 Request: 
2017-03-26 17:15:34 Media type:text/plain 
2017-03-26 17:15:34 Request file:ToJarvis\ccm_pushnotifications_20170326.txt 
2017-03-26 17:15:34 Sending request... 
2017-03-26 17:15:34 
2017-03-26 17:15:34 
2017-03-26 17:15:34 An error occured - while sending the request 
2017-03-26 17:15:34 javax.net.ssl.SSLHandshakeException: Received fatal alert: handshake_failure



 
Environment:
OS Version: N/A
Cause:
Cause type:
Configuration
Root Cause: In order to use either TLS 1.1 or 1.2 Java 1.8 must be used.
Resolution:
Upgrade to Java 1.8 as TLS versions 1.1 and 1.2 are enabled by default. The https.protocols property has no effect on the Apache HTTP client library which the Agent uses.

Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
N/A