Unable to Remove Private APIs from Account Plans

Document ID : KB000073553
Last Modified Date : 15/03/2018
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Issue:
  • When attempting to remove a private API from an Account Plan which is associated with an Organization, no "Remove" button appears.
Environment:
  • This affects all CA API Portal ("Portal")¬†versions between 4.0.x and the latest (4.2.x as of this writing), including both on-premise and SaaS form factors.
Cause:
  • This is working as designed. However, this design can certainly be improved as it can unintentionally cause a poor user experience in some scenarios.
    • An enhancement request exists¬†for improving this design. It is expected to be improved in a future release. This KB article should be updated once that release is known.
Resolution:
  • There is no official process right now, only a workaround. The workaround consists of the following steps:
    1. Create a new Account Plan to replace the one with the incorrect private API added to it.
    2. Migrate Organizations to the new Account Plan which were associated with the previous Account Plan.
    3. Use the new Account Plan, and remove the previous Account Plan.