Unable to register VSE with Remote Registry

Document ID : KB000008496
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

The below sequence is causing an error while connecting to Registry. 

(1)  Start EDB, Registry, Portal and VSE on remote server

(2) Start another VSE on local machine which is configured to connect to the Registry in Step(1)

(3) The below errors are seen in VSE console and VSE.log

Cannot register with the DevTest Registry [Timeout (60,000ms, actual wait 60,000 ms) on server object tcp://<RegistryHost>:<RegistryPort>/Registry on method putVirtualServiceEnvironment]

java.rmi.RemoteException: Timeout (60,000 ms, actual wait 60,000 ms) on server object tcp://<RegistryHost>:<RegistryPort>/Registry on method putVirtualServiceEnvironment 

at com.itko.lisa.net.Transactor.transact(Transactor.java;109) 
at com.itko.lisa.net.ClientBase.transact(ClientBase.java:361) 
... 
... 
... 
... 
... 
at java.lang.reflect.Method.invoke(Method.java:498) 
at com.exe4j.runtime.Method.invoke(Method.java:498) 
at com.install4j.runtime.launcher.UnixLauncher.main(Unknown Source) 

 

Cause:

The remote VSE was able to telnet to Registry's host and port but Registry was not able to telnet to VSE's host and port

Resolution:

For the DevTest components to be able to successfully connect to Registry, it is important that both the servers in question are able to talk to each other over their respective ports. 

For eg, if Registry is running on Machine A port A and any other component like VSE is running on Machine B port B, it is important that both the scenarios described below are successful for the VSE to be able to register with Registry. 

(1) VSE can telnet successfully to Machine A on Port A

(2) Registry can successfully telnet to Machine B on Port B