Unable to open Spectro Server Control Panel

Document ID : KB000006622
Last Modified Date : 14/02/2018
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Issue:

When trying to open the SS Control Panel it fails with following error:

 

"Unable to connect to the location server"

 

 

 

Environment:
WindowsLinux
Cause:

If the Location Server service is down, you may get the above error. The Location Server service, locserv, is managed by the Processd service. 

A few possible causes are: 

1. If processd is down, the locserv will also be down. Restarting processd should also restart locserv and allow Spectrum Control Panel to launch.

Note: The above assumes Location Server service is configured to auto restart with processd (default setting). 

2. A change in the Spectrum Install user password may prevent processd from starting. 

Resolution:

1. Verify the processd process is running. 

  • Windows: Task Manager
  • Linux: top or ps -ef | grep processd

2. If processd is not running, try to restart it.

  • using bash shell, navigate to <SPECROOT>/lib/SDPM
  • run the following command ./processd.pl start

Once processd is restarted, try accessing Spectrum Control Panel

3. If you are still having issue restarting processd, check the processd_log in /SDPM for errors. For example: 

 

Dec 08 11:34:31 Unable to logon user `spectrum` to start server process.

Please set current password using `processd --install --username aabbc-u123456\spectrum --password <passwd>`

 

4. To update the new passwd run the following command:

$SPECROOT/lib/SDPM: processd --install --username user login --password install owner passwd

Verify processd starts and you can access Spectrum Control Panel.

5. If processd and locserv services are running, you may want to check Location Server port is open. 

  • Default port is 14004
  • netstat -ano | grep 14004
  • If you require to change it, please see the following documentation:

https://docops.ca.com/ca-spectrum/10-2-1/en/administrating/distributed-spectroserver-administration/communication-across-firewalls/default-port-configurations

Additional Information:

If the above doesn't solve your case, please continue to search on our knowledge base catalog for further assistance and if you can't find anything please open a case with support.