Unable to Login to DevTest Portal Even Though Portal and Registry are Running

Document ID : KB000117648
Last Modified Date : 22/10/2018
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Issue:
I installed DevTest 10.3 to another Linux VM in our network. I have brought up the EnterpriseDashboardSevice, RegistryService and PortalService. All three show they are running when I to the status entry. The EnterpriseDashboard comes up on the web browser. When I go to the Portal web page it displays. However, when I try the default admin login it says the password is wrong. (We use Derby DB). We have DevTest 10.3 installed on another VM in another security zone. I compared the two displays. The one that is working fine shows the Registry path on the web page. The one that does not work does not show the registry path. I have been able to telnet to port 2010 on the VM, so I believe the port is open. I need assistance is getting the portal up properly so I may login and continue with the installation.
Cause:
The enterprisedashboard.log showing these messages:

Couldn't flush user prefs: java.util.prefs.BackingStoreException: Couldn't get file lock.

This is normally a permissions issue.

When the Registry is started we are seeing these messages: Internal Exception: java.sql.SQLException: Connections could not be acquired from the underlying database! Error Code: 0

Your DevTest 10.3.0 install was done with your user, abc123, but your DevTest services need to be started with function user lisadm, which is what is causing these issues.
Resolution:
Uninstall DevTest 10.3.0 under abc123 account. 

Install DevTest 10.3.0 with the lisadm account.

This will clear up the issues.