Unable to log into UI due to invalid CPs

Document ID : KB000088112
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

Users are unable to log into the UserInterface Java due to invalid CPs.

Investigation
  1. In an active-active system, edit the ucsrv.ini file for both on server A and server B. 
  2. In server A, set CP4=2220. 
  3. In server B, set CP4=3217. 
  4. Save the changes on both the ucsrv.ini. 
  5. Start up CP4. 
Results
Actual:  Users unable to log on while the Automation Engine (AE) continues to attempt to connect to the invalid CPs.
Expected:  The AE detects the CPs are misconfigured and refuses to connect.


 
Cause:
Cause type:
Configuration
Root Cause: Two same CPs were misconfigured to two different ports.
Resolution:
The Automation Engine was not designed to anticipate an admin to incorrectly assign two same CPs to two different ports.

Please open a feature enhancement request at ideas.automic.com and categorize it as "detect misconfiguration".


Fix Status: No Fix

Fix Version(s):
N/A
Additional Information:
Workaround :
In an active-actives system, configure server A to have all odd-numbered CPs and server B to have all even-numbered CPs to minimize misconfigurations.