Unable to load UC4 Version 8 items into a UC4 Verion 9 Database.

Document ID : KB000089387
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Unable to load UC4 Version 8 items into a UC4 Verion 9 Database.
Resolution:
Symptoms

Problems loading  with the load Utility, after upgrade from Version 8 to Version 9 when trying to load unloaded objects from Version 8 into the Version 9 database.?


Investigation

Data needed for Analysis:

  • Logfile of the load Utility

Search for the following error in the Unload Logfile:

U0003518 UCUDB: Invalid value in Boolean field 'OH_OPU_Flag'.

'OH_OPU_Flag' is a table only used in Version 9 not in Version 8.

After having a look into the unload logfile i found out that the unload from version 8 was done with the unload utility from Version 9.

?It is not possible to use a Version 9 utility with a Version 8 Database.

Solution

  • Please perform the unload from Version 8 with a Version 8 utility, and then perform the load into the Version 9 with a Version 9 utility.?