Unable to launch SPECTRUM OneClick even though the required minimum java version has been met. (Legacy KB ID CNC TS30547 )

Document ID : KB000052035
Last Modified Date : 14/02/2018
Show Technical Document Details
A solution to allow for a minimum version of JRE will be provided in Hotfix 4 and above for 9.0. 


 The workaround to allow for a higher version of java is to modify the <SPECROOT>/tomcat/webapps/spectrum/oneclick.jnlp file and add a '+' symbol to the following line:


<j2se version="$$minjre" href=http://java.sun.com/products/autodl/j2se


For example:


<j2se version="$$minjre+" href="http://java.sun.com/products/autodl/j2se"



Related Issues/Questions:
Unable to launch SPECTRUM OneClick even though the required minimum java version has been met.
The version of jre installed is higher than the minimum version of java required, however OneClick will not launch or start
The Required Minimum JRE Version is not working in the JNLP Configuration page for SPECTRUM OneClick.
The version specified in the JNLP Configuration page is the exact version that must be installed.

Problem Environment:
swbug022131
SPECTRUM 9.0 OneClick

Causes of this problem:
On the JNLP Configuration Administration web page the text shows "Required Minimum JRE Version" however it is currently coded as "Required JRE Version".


(Legacy KB ID CNC TS30547 )