Unable to integrate CA Performance Mangement (CAPM) and CA Business Intelligence (CABI) when CABI using SSL

Document ID : KB000106144
Last Modified Date : 12/07/2018
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Issue:
Unable to integrate CA Performance Mangement (CAPM) and  CA Business Intelligence (CABI) when CABI using SSL.

The following error is seen in the DMService.log on CA Performance Center (CAPC)

INFO | jvm 1 | 2018/07/11 15:15:31 | | Received WebServiceException from version check for data source CA Business Intelligence@server.domain.com CAUSE=javax.net.ssl.SSLHandshakeException: SSLHandshakeException invoking https://server.domain.com:443/CABISync/DataSourceWS: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target. MESSAGE=Could not send Message.. Returning DS_COMM_FAILURE result.

 
Environment:
CA Performance Mangement
Cause:
Cannot complete chain of trust to the certificate presented by CABI
Resolution:
You must import the SSL key and any required intermediate/root certificate into the /opt/CA/jre/lib/security/cacerts keystore.
 
On CAPC:
installDirectory/jre/bin/keytool -importcert -keystore installDirectory/jre/lib/security/cacerts -storepass cacertspasswd -alias alias -file filename.cer