Unable to install Spectrum on Linux

Document ID : KB000008253
Last Modified Date : 21/01/2019
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Issue:

Unable to install Spectrum - we observe the below error "Unable to connect to CA Spectrum Remote Administration Daemon (sradmin)". We can confirm SRAdmin is installed and running on port 46517:

 

Screenshot-Unable to Connect.png

 

 

Environment:
All releases of Spectrum being installed on Linux Platform
Cause:

The hostname does not resolve to localhost and IP Address 

Resolution:

-> Run the below commands to find out the IP Address and the hostname of the server respectively: 

ifconfig

hostname 

-> Now, take backup of the /etc/hosts file and edit it as follows: 

 

127.0.0.1 localhost localhost.localdomain <IP Address> <hostname> 

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 

 

For e.g. if the IP Address and the hostname is 192.168.10.91 and testserver respectively, the /etc/hosts file needs to be edited as follows: 

 

127.0.0.1 localhost localhost.localdomain 192.168.10.91 testserver 

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6 

 

-> Now, proceed with the installation, should the issue re-occur, restart the server and try the installation again. 

Additional Information:

Knowledge document KB000056456 "CA Spectrum install fails unable to connect to SRAdmin" located at https://comm.support.ca.com/kb/ca-spectrum-install-fails-unable-to-connect-to-sradmin/KB000056456