Unable to install CA Service Desk Manager 14.1 Cumulative Patch #3 via the Common Installer - installer opens and closes.

Document ID : KB000047652
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue

Unable to install CA Service Desk Manager (CA SDM) 14.1 Cumulative Patch #3 via the Common Installer.  The Common Installer opens and closes almost immediately.

The Common Installer STDERR log file shows:

theException = ExceptionInInitializerError 

The Common Installer INSTALL log file shows 

INFO [main] [CommonUtil] pdm_server_control input = STANDBY 
INFO [main] [ConfigUIUtils] SDM ServerType :Standby 
INFO [main] [ConfigUIUtils] SDM Local Servlet URL :http://sdmserver:8080 
INFO [main] [ConfigUIUtils] SDM CGI Url = 

Environment

CA Service Desk Manager 14.1

Installing CA Service Desk Manager Cumulative Patch #3 via the Common Installer

Cause

The NX.ENV file on the CA SDM server has the following entry:

! @NX_WEB_CGI_URL=No URL defined for: 

Solution

1. Backup the NX.env file present on the CA SDM server 

2. Locate the above line for @NX_WEB_CGI_URL, and replace with this line: 

@NX_WEB_CGI_URL=http://<SDM Server Hostname>:8080/CAisd/pdmweb.exe 

For example

@NX_WEB_CGI_URL=http://sdmserver:8080/CAisd/pdmweb.exe 

3. Save the NX.env file and  then try running the Common Installer for CA SDM 14.1 Cumulative Patch #3 

Additional Information

Implementing CA Service Management 14.1.03 - https://docops.ca.com/ca-service-management/14-1/en/implementing/implementing-ca-service-management-14-1-03