Unable to Install CA Embedded Entitlements Manager (EEM) due to 'wrong ELF class: ELFCLASS64' Error

Document ID : KB000007767
Last Modified Date : 14/02/2018
Show Technical Document Details

We are getting the following error message while trying to install EEM:


│ /opt/CA/SharedComponents/tmp/CASockAdapterSetupLinux.bin: error while loading shared libraries: │ 

│ libstdc++.so.6: wrong ELF class: ELFCLASS64 


CA Embedded Entitlements Manager r12.51+

The installation is failing because the CASockAdapterSetupLinux.bin found the 64-bit version of the libstdc++.so.6 library.


Install the 32-bit version of the libstdc++ library before installing EEM.