Unable to import UPM Patches

Document ID : KB000045895
Last Modified Date : 14/02/2018
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Problem :

Patch management is in offline mode. Import of UPM patches is not working.
 
In DSM Web Console under Patch Management/Patches, in tab Offline Patches, the path for CIC_Offline_Export.xml file is filled. Click on Accept button in order to show the patches available for importation.
 
When selecting 1 patch and click in Import button, nothing happens. The patch is not imported. In import patch location, nothing appears.
 
Untitled.jpg
 
 
 
In file <DSM PATH>\logs\wac_log.log following lines could be found at date/time of importation attempt :
 
 
07/27 11:00:16.318[ImportPatchTask] INFO  ImportManager.fnLogEvent(192)  - Import Location specified in the MDB - c:\temp
07/27 11:00:16.318[ImportPatchTask] ERROR ImportManager.fnLogEvent(196)  - An unexpected exception ocurred processing patches for Import. Error: Index: 2, Size: 2
07/27 11:00:16.318[ImportPatchTask] DEBUG ImportManager.fnLogEvent(190)  - Trace: java.util.ArrayList.rangeCheck(ArrayList.java:653)
07/27 11:00:16.318[ImportPatchTask] DEBUG ImportManager.fnLogEvent(190)  - Trace: java.util.ArrayList.get(ArrayList.java:429)
07/27 11:00:16.318[ImportPatchTask] DEBUG ImportManager.fnLogEvent(190)  - Trace: com.ca.wac.pm.manager.ImportManager.doImport(ImportManager.java:167)
07/27 11:00:16.318[ImportPatchTask] DEBUG ImportManager.fnLogEvent(190)  - Trace: com.ca.wac.pm.decision.ImportPatchTask.run(ImportPatchTask.java:84)
07/27 11:00:16.318[ImportPatchTask] INFO  ImportPatchTask.fnLogEvent(192)  - Import Patch(es) Processing Complete

 

 
 
 

Environment: 

CA Client Automation 14.0
 
 
 

Cause:

 
This problem is resolved by fix T53G099 for CA ITCM 14.0.
 
Please open a support issue in order to get this fix.