Unable to get CPU data with the cdm probe

Document ID : KB000037586
Last Modified Date : 30/07/2018
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Issue:

The cdm probe is unable to collect CPU or Memory metrics on a Windows server.  You may see errors similar to the following in the cdm.log file at loglevel 5:

cdm: CheckCpuInfo - GetCpuInfo failed (error)
cdm: ntgetuptime: Unable to get the 'System Up Time' counter of the 'System' performance object

 

Environment:
Any supported version of the cdm probe installed on a support Windows server.
Cause:
The cdm probe fetches performance objects for Processor, Memory and System directly on Windows servers (Windows perfmon utility). If the probe is not able to retrieve the values of these counters, QoS metrics cannot be collected.
Resolution:
Reset all the performance counters by executing the following command on your Windows server in a cmd prompt window:

cd c:\windows\system32 
lodctr /R 

cd c:\windows\sysWOW64 
lodctr /R 


Reboot the Windows Server to take effect


Also via regedit, take note of:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\PerfProc\Performance

In this key, there could be a Disable Performance Counters value that is set to 1. You may have to reset that value to 0, and then Deactivate and Activate the cdm probe

PerfMOn Counter Disabled

Microsoft Technical note:
- Microsoft Counter Library rebuild, please follow next steps:
[How to manually rebuild Performance Counter Library values]

https://support.microsoft.com/tr-tr/help/300956/how-to-manually-rebuild-performance-counter-library-values


1. Deactivate the probe.
2. Delete the probe from robot.
3. Delete the physical folder from robot server.
4. Redeploy the probe again.
5. Test
Additional Information:

Use Performance Monitor to verify that the performance counter is present and returning data

perfMon - Counter Select

perfMon - Counter Data