Unable to duplicate or copy more than 20 blocks in Agile Requirements Designer

Document ID : KB000047300
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

In Agile Designer, we are unable to use the deduplication feature or copy more than 20 blocks for our flows. After duplicating or copying over 20 blocks, we receive the error message 'You are only licensed for 20 blocks when de-duplicating- please contact sales.' On our license information page, we see a limit called 'De-duplicate block limit: 20'. We have purchased the product and no longer have a trial version, so we should not have this limit. 

To see license limit message:

  1. In Agile Designer, click on the 'Help' tab in the toolbar.
  2. Choose the 'License Information' option from the list.
  3. In the window that appears, you can see that it says 'De-duplicate block limit: 20'.

    de-duplicate block limit.png

To see block limit message:

  1. Create a new flow or use an existing flow.
  2. Add a process block to the flow.
  3. Right-click on the process block.
  4. Choose 'Duplicate block' from the list. (You can also replicate the issue by using the 'Copy' function)
  5. Click anywhere on the canvas.
  6. A window will appear prompting you to enter a 'Name' for the block. Enter a name and click the 'OK' button.
  7. Repeat this process 20 times.
  8. After trying a 21st time, you will receive the error message 'You are only licensed for 20 blocks when de-duplicating- please contact sales.' 

    you are only licensed for 20 blocks.PNG

Environment:  

CA Agile Requirements Designer (ARD)- Agile Designer

Causes: 

If you have purchased the product and applied a full ARD license, this is a defect which will require a patch to fix.

If you have purchased the product, but are still using your trial license, then this is a true license limitation. 

If you are still using a trial version of the product, this is a known limitation placed on all trial versions and licenses. 

If you have purchased the product, applied a full ARD license, are seeing the 'de-duplication limit' message in the licensing window, but not experiencing any error messages when duplicating more than 20 blocks, then this is a cosmetic issue which we can provide a patch for.

Resolutions:

If you have purchased the product and applied a full ARD license, this is a defect which we can provide a patch for. 

  1. Open a support case by going to https://support.ca.com/irj/portal/newhome or calling CA Customer Care at one of these numbers http://www.ca.com/us/company/contact-us.html.
    • Please include a reference to this knowledge document, TEC1744661.

  2. Support will provide a patch and upload it to the support case. Here are instructions on how to download the patch:
    • Login to https://support.ca.com/irj/portal/anonymous/newhome 
    • Hover over the 'Case Management' icon and choose 'View Cases' from the list that appears. 
    • Enter in the support case number in the search field text box.
    • Click the 'Go' button. 
    • Click on the case number from the results list. 
    • Click on the 'File Attachments' tab. 
    • Choose the 'File Transfer Using Thin Client' option. 
    • Click on the 'files_from_CA' button.
    • Choose the file you need to download. 
    • Click the 'Download' button. 

  3. Apply the patch using these steps:
    • Take a backup copy of your ARD directory folder and place it outside the GridTools folder. The default location for that is C:\Program Files\Grid-Tools\AgileDesigner.
    • Execute the setup_AgileDesigner_2.X.XXX.XX.exe file that you downloaded. This will be an installer. Go through the installation steps until finished.
    • Restart Agile Designer by either double clicking on the icon on your desktop, or by going to C:\ProgramFiles\Grid-Tools\AgileDesigner and double clicking on the AgileDesigner.exe. 
    • Re-test using more than 20 de-duplicated blocks. 

If you have purchased the product, but are still using your trial license, we recommend requesting and applying for a full ARD license. 

  1. Follow the steps in this document to request and apply an offline license: http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1147813.html  

    OR

  2. Follow the steps in this document to request and apply an online license: http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1424828.html 

If you are still using a trial version of the product, but would like a less limited license, we recommend reaching out to your CA Account Manager.

  1. Reach out to your CA Account Manager to see if you are able to have a full ARD license during your trial period. If you do not know who your account manager is, please call CA Customer Care at one of these numbers http://www.ca.com/us/company/contact-us.html and they will be able to provide the correct contact information.

  2. After they have approved a less limited license, follow the steps in one of the documents below to receive either an offline or online license:

If you have purchased the product, applied a full ARD license, are seeing the 'de-duplication limit' message in the licensing window, but not experiencing any error messages when duplicating more than 20 blocks, then this is a cosmetic issue which we can provide a patch for.

  1. Open a support case by going to https://support.ca.com/irj/portal/newhome or calling CA Customer Care at one of these numbers http://www.ca.com/us/company/contact-us.html.
    • Please include a reference to this knowledge document, TEC1744661.

  2. Support will provide a patch and upload it to the support case. Here are instructions on how to download the patch:
    • Login to https://support.ca.com/irj/portal/anonymous/newhome 
    • Hover over the 'Case Management' icon and choose 'View Cases' from the list that appears. 
    • Enter in the support case number in the search field text box.
    • Click the 'Go' button. 
    • Click on the case number from the results list. 
    • Click on the 'File Attachments' tab. 
    • Choose the 'File Transfer Using Thin Client' option. 
    • Click on the 'files_from_CA' button.
    • Choose the file you need to download. 
    • Click the 'Download' button. 

  3. Apply the patch using these steps:
    • Take a backup copy of your ARD directory folder and place it outside the GridTools folder. The default location for that is C:\Program Files\Grid-Tools\AgileDesigner.
    • Execute the setup_AgileDesigner_2.X.XXX.XX.exe file that you downloaded. This will be an installer. Go through the installation steps until finished.
    • Restart Agile Designer by either double clicking on the icon on your desktop, or by going to C:\Program Files\Grid-Tools\AgileDesigner and double clicking on the AgileDesigner.exe. 
    • Re-test using more than 20 de-duplicated blocks. 

Additional Information:

If you experience any issues, please open a support case by going to https://support.ca.com/irj/portal/newhome or calling CA Customer Care at one of these numbers http://www.ca.com/us/company/contact-us.html