"Unable to determine the Gateway version you are running!" error seen when integrating CA API Developer Portal 3.5 or 3.5CR1 with CA API Gateway 9.1.00.

Document ID : KB000004487
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When installing a base version 3.5 or 3.5CR1 of CA API Developer Portal with version 9.1.00 of CA API Gateway, a user may be presented with an error stating "Unable to determine the Gateway version you are running!".

Environment:
This applies to any fresh installations or upgrades to CA API Developer Portal version 3.5 or 3.5CR1.
Cause:

The CA API Developer Portal versions 3.5 and 3.5CR1 were released prior to the CA API Gateway version 9.1.00 debut. As such, those versions of the CA API Developer Portal component / integration scripts for CA API Gateway (setup-ssg-3.5.sh and base35-package.tgz) do not recognize version 9.1.00 of CA API Gateway, which will prevent the installation and throw the error. Versions 3.5 and 3.5CR1 of CA API Developer Portal are not compatible with version 9.1.00 of CA API Gateway.

Resolution:

This problem was resolved in 3.5CR2, as the CA API Gateway integration scripts when used with CA API Developer Portal were updated to be aware of CA API Gateway version 9.100. Using 3.5CR2 instead of 3.5 or 3.5CR1 will bring compatibility between the CA API Developer Portal and CA API Gateway running 9.1.00.

Upgrading to the latest cumulative release of 3.5 CA API Developer Portal can be found in the product documentation.

 

Additional Information:

The latest CA API Management product suite solutions, patches, and cumulative releases can be downloaded from the CA API Management Solutions and Patches page. This includes downloads for CA API Gateway, CA Mobile API Gateway, and CA API Developer Portal.