Unable to create new tasks in PPM

Document ID : KB000005891
Last Modified Date : 06/08/2018
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Issue:

Unable to create new tasks in PPM. When clicking the New button, it returns you to an existing task. If trying to create a task from the  PPM Gantt, you may instead receive error "Action Not Allowed"

Steps to Reproduce:

1. Log in to PPM 

2. Navigate to a project in the classic UI (Home->Projects->Click on a project)

3. Make sure at least one resource is added to the team tab 

4. Create a new task and assign the resource to the task 

5. Scroll down to the Assignments section, and click the '<' or '>' buttons in the ETC BY Period section (Time Scaled Value section)

6. Click 'Return' to leave the current task 

7. Click 'New' to create a new task 
 
Expected Results: Create task view is shown to create a new task 

Actual Results: An existing task’s details are displayed. If trying to create a task from the  PPM Gantt, you may instead receive error "Action Not Allowed".
 
Environment:
This applies to CA Project & Portfolio Management (PPM) 14.4, 15.1 and 15.2
Cause:

This is caused by DE32167

Resolution:

This issue DE32167 is fixed as of CA PPM 14.4 patch 7, 15.1 patch 5, and 15.2 patch 1 and 15.3. (Note: Patches are cumulative, so the latest patch for each release will also contain the fix)

Workaround:

1. To prevent the issue from occurring: Don't click on the '<' or '>' buttons in the ETC BY Period section (Time Scaled Value section) in the Task Assignments instead you can use the below steps to see data in different TSV periods:

  •  Click on a task
  • Click on Options->Time-Scaled Value in the right hand corner of the Assignments section
  •  Update the Start Date section to move the periods that want to be viewed forward or backward

2. If the issue does occur, to remove the symptoms:

  • Restart the app services which will remove the symptoms.
  • Flush the PPM cache using the steps found at: KB000098199 (Flushing the Groups Cache is not needed for this issue)