Unable to create new tasks in PPM

Document ID : KB000005891
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Unable to create new tasks in PPM. When clicking the New button, it returns you to an existing task. 

Steps to Reproduce:

1. Login to PPM 

2. Navigate to a project in the classic UI (Home->Projects->Click on a project

3. Make sure at least one resource is added to the team tab 

4. Create a new task and assign the resource to the task 

5. Scroll down to the Assignments section, and click the '<' or '>' buttons in the ETC BY Period section (Time Scaled Value section)

6. Click 'Return' to leave the current task 

7. Click 'New' to create a new task 
 
Expected Results: Create task view is shown to create a new task 

Actual Results: An existing task’s details are displayed 
 
Environment:
This applies to CA PPM 14.4, 15.1 and 15.2
Cause:

This is caused by DE32167

Resolution:

This issue DE32167 is fixed in 14.4 patch 7, 15.1 patch 5, 15.2 patch 1 and 15.3.

Workaround:

1. To prevent the issue from occurring: Don't click on the '<' or '>' buttons in the ETC BY Period section (Time Scaled Value section) in the Task Assignments instead you can use the below steps to see data in different TSV periods:

  1.  Click on a task
  2. Click on Options->Time-Scaled Value in the right hand corner of the Assignments section
  3.  Update the Start Date section to move the periods that want to be viewed forward or backward

2. If the issue does occur: Restart the app services which will remove the symptoms.