Unable to create or update ACC Java Agent package after upgrading to 10.7 SP1

Document ID : KB000102668
Last Modified Date : 04/07/2018
Show Technical Document Details
Issue:
After importing 10.7 SP1 ACC agent bundles, both the 10.70.45 and 10.7.0.90 agent packages in available from the ACC UI
User-added image
However, when creating a new Agent package or updating the bundles of an existing one the following error message appears:

EA0500:Caught exception:Only 1 java-agent bundle should be selected. Currently selected java-agent bundles [(id=17, name=java-agent, ver=10.7.0.45), (id=77, name=java-agent, ver=10.7.0.90)]

User-added image

How do I resolve this?
Environment:
APM 10.7.0 SP1
Cause:
The problem affects only the Java agent and it is related to defect DE369851
Resolution:
Workaround: none

Solution: the fix to this issue is included in the below agent packages:
- 10.7 Hotfix #10
- 10.7 SP2 

Contact CA Technical Support for access to these hotfixes.
 
Additional Information: