Unable to connect agent after upgrading agent to 6.6

Document ID : KB000121663
Last Modified Date : 29/11/2018
Show Technical Document Details
Issue:
After attempting to upgrade 2 agents via Automation Studio to version 6.6 the agents are not connecting. On the agent machine we see that the agent processes are not running. While trying to start them we are getting 2 errors.

When attempting to start the agents we are getting following 2 errors:
  1. cp: cannot stat `/path/to/agentInstallDir/jre/bin/java': No such file or directory somehow binary file `/path/to/agentInstallDir/jre/bin/java' is missing
  2. Environment Variable 'LANG' not set. 
Environment:
CA Release Automation 6.6
RHEL 6.9
 
Cause:
The cause was a failed attempt to upgrade the agent. The root cause was not identified. 
Resolution:
Run the Agent Install from Automation Studio making sure to point it to a folder that does not conflict with the existing install. 

NOTE:
If root cause is needed please open an issue.