Unable to configure VMWARE probe

Document ID : KB000092775
Last Modified Date : 17/05/2018
Show Technical Document Details
Issue:
I am unable to configure a new profile for the vmware probe. When I add a new resource with the details of my VCenter server and click on the Test button it fails with the following error:

Failed to query the host <vmware host name>. 
The reason for this could be one of many. Please check: 

- The hostname or ip address is illegal or wrong. 
- The pot number is wrong. 
- The handler class is wrong. 

Exception log: 
(12) login failed, VMWare API is unavailable: Exception caught trying to invoke 
method RetrieveServiceContent; nested exception is: 
    java.net.ConnectException: Connection timed out: connect: Exception 
caught trying to invoke method RetrieveServiceContent; nested exception is: 
    java.net.ConnectException: Connection timed out: connect 

Check the probe logfile for more information. 
Cause:
This could be caused by many different reasons but it basically means that the probe is unable to reach the vmware device. Reasons would include a bad DNS entry, unable to resolve the IP address or firewall issues.
Resolution:
Make sure you have:
  • entered the correct information in the 'Hostname or IP Address' field;
  • tested the name resolution from the robot where the vmware probe is running against the hostname used in the previous step;
  • specified the correct port for the vmware webservice;
  • ensured that the port specified in the previous step is open in the firewall, meaning that the robot has access to the vmware system on that port.