Unable to configure clustered node of ITPAM

Document ID : KB000005455
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Unable to install a secondary domain cluster node for CA Process Automation. The installation appears as if it starts, but the window just disappears and the installation does not continue.

Environment:
Windows Server 2008, 2012Java SDK 1.7 or 1.8CA Process Automation, and version from 4.2 through 4.3 SP01
Cause:

This is usually due to a permissions issue for Java

Resolution:

To resolve the issue, the following should be done:

1. Check that Java on the machine where you are installing is using Direct Connection. Open the Control Panel and select Java, then select the Network Settings button from the General tab 

2. On the secondary machine where the JNLP has been downloaded, please open an elevated command prompt (Run As Administrator), and type the following javaws -viewer 

3. The Java Control Panel will open, then the Java Cache Viewer will open. In the Java Cache Viewer, select the installation jnlp file, then click on the Run button - Green Arrow icon. 

This will start the installation and you can complete it as necessary. 

 

Additional Information:

Make sure that User Account Control is set to "Never" during the installation as well as this will cause popups in the background of the installation that can never be responded to as they will not come forward. 

Once the installation has completed, the access control should be set as low as possible on your server.

One other thing we have found is that if you are using NGiNX as your load balancer, and you have copied the conf files from another NGiNX installation (perhaps a test install), if you do not comment the lines in the pam-server.conf file that are specific to node2 before you start the installation of the second node, the installation will not run. 

Make sure if you are copying over files, that any references to the additional nodes are commented before beginning the install.