Unable to clear Alarms

Document ID : KB000107811
Last Modified Date : 25/07/2018
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Issue:
When I manually try to clear an Alarm, I get the error message:

The syntax error below was found in XML file: service-desk-config.xml please contact administrator to resolve the issue, then restart this client.
Error on line-1: Premature end of file
Environment:
Spectrum 10.X
Cause:
The <SPECROOT>/custom/svdsk/config/service-desk-config.xml store the settings for the Spectrum/Service Desk integration. 
The problem is usually related to an empty file, or corrupt file
 
Resolution:
To resolve the problem, the steps are as follow: 

1. Remove the following file from the OneClick server: 
<SPECROOT>/custom/svdsk/config/service-desk-config.xml 

2. Make a copy of the following file: 
<SPECROOT>/tomcat/webapps/spectrum/WEB-INF/svdsk/config/service-desk-config.xml 

3. Place the copied file in the following directory: 
<SPECROOT>/custom/svdsk/config/ 

4. Restart the tomcat service. You should be able to clear the alarm after this.

Another possible solution is to do only step 1, and then browse to OneClick page, Click on Administration tab, and then on Service Desk Configuration.
Modify the settings for the integration as needed, and click on "Save" button to save the changes (bottom of the page). A new service-desk-config.xml file will be created on <SPECROOT>/custom/svdsk/config/. You should be able to clear the alarm after this.
Additional Information:
Product Documentation.
https://docops.ca.com/ca-spectrum/10-2-3/en