Unable to adjust a timesheet row for an incident if the application holding the incident is closed for time entry in PPM

Document ID : KB000124911
Last Modified Date : 15/02/2019
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Issue:
Unable to adjust a timesheet row for an incident if the application holding the incident is closed for time entry in Clarity PPM. However I am able to post time against the same incident, even if the application is closed for time entry. 

Steps to Reproduce:

1. Go to Home > Portfolio Management > Applications 
2. Create an application
3. Go to the Application Settings subpage and ensure the Open for Time Entry flag is off
4. On the Incident categories sub menu, select any of the available categories
5. On the Incidents sub menu, create an incident 
6. Ensure the resource you are logged in with is Open For Time entry and has got PPM as track mode 
7. Go to the timesheets list 
8. Open a timesheet for the logged in resource and click on the Add Incident button 
9. Enter time against the incident.
10. Submit, approve and post the timesheet 
11. Edit the timesheet and try to adjust the incident time entry 

Expected Results: Timesheet row to be editable to adjust the time entry 
Actual Results: The row is read only because the application the incident is linked to is closed for time entry 
Cause:
This issue is caused by DE46557
Resolution:
This issue is fixed in Clarity PPM 15.6.

Workaround: Open the application for time entry