Unable to access OC Admin page following addition of new Landscapes.

Document ID : KB000097165
Last Modified Date : 18/05/2018
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Issue:
Following the addition of some new Landscapes to our DEV install area, to make it a mirror of PROD, I'm unable to access the OC Admin home page. This is the original pre-existing OC server that was already in place before the additions. Likewise, the MLS tied to this OC instance was already in place as well. The ONLY change made to the original OC install was an update to its .hostrc to include all the new Landscapes, etc.
Environment:
Spectrum 10.2.2

Linux RHEL 7
Cause:
A File editor was used to create the .hostrc files which were then propagated to all servers. In some cases file editors may imprint formatting which then makes the file difficult to read by the SpectroSERVER. When this happens, the .hostrc cannot be read and communication issues between servers arises.
Resolution:
Try creating a new .hostrc file on the server itself using a built-in editor such as VI

Copy the contents of the original .hostrc, and rename the .hostrc as .hostrc_old

Create a new .hostrc using VI editor and paste the contents

Save the file

Do the same for MLS and OC and test login connection,. If it works, then do the same on the other servers