Unable to access BSI Application

Document ID : KB000094903
Last Modified Date : 07/05/2018
Show Technical Document Details
Issue:
Unable to access BSI Application - 
The following message is shown in the web browser: "Retrieving the COM class factory for component with CLSID {2A4E2631-81FC-4669-8C84-A8E0C2E22C7A} failed due to the following error: 8000401a the server process could not be started because the configured identity is incorrect. Check the username and password. (Exception from HRESULT: 0x8000401A)." It seems that there is some authentication problem but we are not able to find the component with the corresponding CSLID in the registry nor in the COM Config.
Environment:
BUSINESS SERVICE INSIGHT 8.3.5
Cause:
The problem was that the password for the user through which configuration for BSI was done had been changed
Resolution:
If BSI installation user's password is changed, in order to normalize the system configuration it's necessary to do the following:

1) Change logon passwords on required Oblicore services.

2) Change identity password on Oblicore engine COM+ application.