ITAM 17.1: Unable to access CA APM web interface

Document ID : KB000099475
Last Modified Date : 13/02/2019
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Issue:
After installing CA APM 17.1, when firing up CA APM, there is an error:

HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid
Cause:
This is caused by incorrect configuration of IIS.
Resolution:
Fire up "Server Manager", select "Add Roles or Features", click through to "Server Roles", can you expand:

Web Server (IIS)
  Web Server
    Application Development

Ensure that you have these options selected:

User-added image
Additional Information:
Related articles:

A HTTP Error 500.19 - Internal Server Error is received after performing the CA Asset Portfolio Manager 14.1.02 post installation steps.
https://comm.support.ca.com/kb/a-http-error-50019-internal-server-error-is-received-after-performing-the-ca-asset-portfolio-manager-14102-post-installation-steps/kb000033249

HTTP Error 500.19 Internal Server Error
https://comm.support.ca.com/kb/http-error-50019-internal-server-error/kb000048785

CA APM ITAM webservice wsdl test not working - 404 File not found
https://comm.support.ca.com/kb/ca-apm-webservice-not-working-404-file-not-found/kb000095544