UMP home page showng Tomcat 404 error

Document ID : KB000004340
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Following the deployment of ump_servicepack_metapackage connecting to the UMP home Tomcat report 404.ried logging in as administrator with same result.

When trying to login as administrator, wasp.log shows the following message.
Oct 21 11:00:00:117 WARN [http-bio-80-exec-10, com.nimsoft.udm.utilities.nimbus.UdmConnectionLookup] Waiting to obtain UDM database connection properties: (11) command not found, Received status (11) on response (for sendRcv) for cmd = 'getUdmDatabaseConnection' Retrying...

 

Environment:
During the upgrading UMP 8.4XEven following up the below steps1) Stopped wasp2) deleted the old copy of wasp/webapps/ROOT that I restored3) used wasp->configure->ROOT->refresh webapps to flag performing a refresh4) restarted waspwasp/webapps/ROOT was refreshed and now html/version.txt is reporting UMP_842_GA as expected.Now able to login but USM sits at LOADING....
Cause:

As the following message is repeated in wasp.

Oct 21 12:12:00:123 WARN [http-bio-80-exec-10, com.nimsoft.udm.utilities.nimbus.UdmConnectionLookup] Waiting to obtain UDM database connection properties: (11) command not found, Received status (11) on response (for sendRcv) for cmd = 'getUdmDatabaseConnection' Retrying... 

 As well as message in udm_manager log such as 

Exception establishing Datomic connection: :db.error/not-enough-memory (datomic.objectCacheMax + datomic.memoryIndexMax) exceeds 75% of JVM RAM.

It is a shortage of JVM memory size.

 


Resolution:

Once this error from udm, was able to look at the datomic settings and adjust the JVM size.

It resolves the problem