UIM Visual C++ 2005 and 2008 Dependency

Document ID : KB000095321
Last Modified Date : 11/05/2018
Show Technical Document Details
Question:
UIM is dependent on Visual C++ 2005 and 2008, since Visual C++ 2005 is EOL and support for 2008 is ending soon, is it ok to replace them with more current version?
Answer:
UIM uses VC++ 2008 (also uses VC++2005). The dependency on VC++ 2005 will be removed in next release of UIM 9.x. Removing UIM dependency on VC++ 2008 is under consideration but most likely not happen in next release because there are product architectural challenge that needs to be overcome and requires redesign of the product.