UIM - Unable to start cabi probe for CABI installation

Document ID : KB000125213
Last Modified Date : 24/01/2019
Show Technical Document Details
Issue:
Installed cabi probe on the robot for CABI installation . However, the cabi probe keeps failing to start.

Can see the below errors in the cabi logs


Jan 22 23:06:41:252 [main, cabi] changing probe state from 'INSTALLING_CABI' to 'STARTING_WASP'
Jan 22 23:06:41:252 [main, cabi] activating wasp...
Jan 22 23:06:41:252 [main, cabi] waiting for wasp to start...
Jan 22 23:07:26:268 [main, cabi] wasp has started  [time taken=0 minute(s) 45 second(s) (45016 ms)]
Jan 22 23:07:26:268 [main, cabi] getting wasp port ...
Jan 22 23:07:26:268 [main, cabi] waiting for cabi webapp @ http://xxx.xx.xx.xx:80/cabijs to start responding ... 
Jan 22 23:17:28:255 [main, cabi] java.util.concurrent.TimeoutException: cabi webapp at 'http://xxx.xx.xx.xx:80/cabijs' failed to start in 10 minutes
    at com.ca.cabi4uim.utilities.ProbeUtils.waitForWaspAndWebappToStartupCompletely(ProbeUtils.java:1541)
    at com.ca.cabi4uim.Probe.makeSureCabijsWebappIsUp(Probe.java:413)
    at com.ca.cabi4uim.Probe.createRestUser(Probe.java:550)
    at com.ca.cabi4uim.Probe.setupCabiInBundledMode(Probe.java:354)
    at com.ca.cabi4uim.Probe.setupcabi(Probe.java:281)
    at com.ca.cabi4uim.Probe.initOnTimer(Probe.java:620)
    at com.nimsoft.nimbus.NimProbe.doForever(NimProbe.java:418)
    at com.ca.cabi4uim.Probe.run(Probe.java:805)
    at com.ca.cabi4uim.Probe.main(Probe.java:111)
    
Jan 22 23:17:29:649 [5040] Controller: Probe 'cabi' (command = <startup java>) returns no-restart code (42)
Environment:
UIM 8.51
cabi 3.2
Bundled cabi install
Resolution:
In this scenario default port 80 was used for cabi which is specified as http_port in wasp 
  • Deactivate wasp and cabi probe and check if port 80 ( or whatever port specified ) is free using netstat 
  •  In this case port 80 was being used by some other OS application for example iis even though wasp probe got active as seen in Infrastructure Manage with port and pid.          
  •  Free up the port and follow the cabi procedure to reinstall again which should be successful now.
Additional Information:
https://docops.ca.com/ca-unified-infrastructure-management/8-5-1/en/installing-ca-uim/ca-business-intelligence-with-ca-uim/installing-and-upgrading-ca-business-intelligence-jasperreports-server-with-ca-uim/install-or-upgrade-for-an-external-ca-business-intelligence-jasperreports-server