UIM - UMP fails to bind to port 80

Document ID : KB000109329
Last Modified Date : 06/08/2018
Show Technical Document Details
Issue:
UMP will stop working, and there will be a popup error. Refreshing, restarting does not help. Checking wasp log and TCP port usage for port 80 (the default) it can be seen that wasp can no longer connect to port 80. 
Environment:
Windows 2012 R2
Resolution:
To temporarily get it working, reboot the server hosting the UMP robot. 

This issue is resolved in KB4338831.
​https://support.microsoft.com/en-us/help/4338815/windows-81-update-kb4338815

This can also happen if the "World Wide Web Publishing Service" is running on the UMP robot. 

A workaround is to reconfigure wasp to use a different port like 8080. 
Additional Information:
The wasp log shows the failure to get port 80.
Jul 30 13:15:07:868 INFO [main, com.nimsoft.nimbus.probe.service.wasp.Probe] AJP connector max threads 250 
Jul 30 13:15:08:102 INFO [main, org.apache.coyote.http11.Http11Protocol] Initializing ProtocolHandler ["http-bio-80"] 
Jul 30 13:15:08:118 ERROR [main, org.apache.coyote.http11.Http11Protocol] init() Failed to initialize end point associated with ProtocolHandler ["http-bio-80"] 
Jul 30 13:15:08:118 ERROR [main, org.apache.coyote.http11.Http11Protocol] java.net.BindException: Address already in use: JVM_Bind <null>:80 
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:413) 
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:650) 

Microsoft security update KB4338815 has this known problem:
https://support.microsoft.com/en-us/help/4338815/windows-81-update-kb4338815

Restarting the SQL Server service may fail occasionally with the error, “Tcp port is already in use”.     
This issue is resolved in KB4338831.
https://support.microsoft.com/en-us/help/4338815/windows-81-update-kb4338815

Which apparently is also resulting in this problem for wasp.