UIM is not able to publish alerts to UIM - SOI connector due to the timeout error

Document ID : KB000004496
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

On the SOI console, if you cannot see any new alerts coming from the UIM connector. On the UIM connector, after enabled the debug options and restarted the Catalyst container service, you don't see anything has been published under ...\CA\Catalyst\CatalystConnector\container\data\log\EIDebugData and ...\Catalyst\CatalystConnector\ifw\log\debugData directories.

If you found the following error from Nimsoft\hub\hub.log file from the UIM server, then this KB article will be applicable for you.

hub: Reply not received on queue route for 'Catalyst' (timeout), disconnecting

 

Environment:
Hub 7.xUIM connector 3.xSOI 3.x, 4.x
Cause:

After upgrading to hub 7.x, some customers have experienced instability and connectivity issues between tunneled hubs, including queue connectivity failures and frequent tunnel disconnections.

In this case, the Hub failed to connect to the "Catalyst" queue after reached out the default queue timeout value.

Resolution:

Edit the ...\Nimsoft\hub\hub.cfg and find the <hub> section. In that section, adjust the following keys (most should exist already, but if any do not, you may add them.)

postroute_interval = 120
postroute_reply_timeout = 180
postroute_passive_timeout = 300
hub_request_timeout = 120
tunnel_hang_timeout = 300
tunnel_hang_retries = 3

On systems with very low latency and fast response between hubs, it may be beneficial to decrease tunnel_hang_timeout to 120, or even 60.

Once you have made these changes and save the file, it will automatically restart the Hub to take effective.