UIM Infrastructure Manager console fails to login

Document ID : KB000109066
Last Modified Date : 06/08/2018
Show Technical Document Details
Issue:
When trying to use the IM Manager console, login fails with the message "unable to locate specified domain". 
Environment:
The UIM server Primary Hub is installed on a Linux system. 
Resolution:
For communication from the system running the IM Manager console to the system running the hub ports 48000 to 48020 need to be open. 
Additional Information:
Since the hub is running on a Linux system, the IM Manager must be installed and run from a Windows system. 

The IM Manager log is located at:
$\nimsoft\AC\logs\nimbus_manager.log

Jul 31 16:31:12:747 [0956] Infrastructure Manager: nimSessionNew - _probeCheckin failed - communication error 
Jul 31 16:31:22:749 [0956] Infrastructure Manager: Warning - Request (gethub) has timed out (timeout interval: 10 sec) 
Jul 31 16:31:22:750 [0956] Infrastructure Manager: gethub - x.x.x.x - communication error 
Jul 31 16:31:24:858 [0956] Infrastructure Manager: Warning - Login failed for hub: x.x.x.x (Cannot locate specified domain) 

After increasing the timeout additional info was in the log. 
To increase the timeout open regedit.exe and go to:
HKEY_CURRENT_USER\Software\Nimbus Software\NimBUS Manager\Options
set RequestTimeout & RequestTimeoutCfg both to 60 

now log has:
Infrastructure Manager: sockConnect - connect to ::1 48000
Infrastructure Manager: nimRequest: SessionConnect failed ::1 48000
Infrastructure Manager: nimSessionNew - _probeCheckin failed - communication error

From the system running the IM Manager console used telnet to test the connection and it failed
telnet <hub IP address> 48000

To add telnet go to Control Panel > Programs > at the top left click Turn Windows features on or off > check the box for telnet > click OK