UIM Discovery Wizard error "Unable to acquire version information"

Document ID : KB000072601
Last Modified Date : 30/07/2018
Show Technical Document Details
Issue:
When launching discovery wizard for the secondary hubs with discovery agent, it will pop up "Unable to acquire version information.
The only discovery wizard that is working is on primary hub.
Primary hub to secondary hubs are tunnel hubs.
Environment:
UIM/UMP 8.51 

hub version:
-Primary: 7.93 
-Secondary: 7.93 

discovery_server v8.52(on Primary)
discovery_agent v8.52 (on Secondary)
Resolution:
Enabling access to tunnel-proxy-port (for secondary hub) in the primary hub from UMP robot will solve this issue.

e.g. 

Primary hub(tunnel server) - 192.168.100.10 
Secondary hub(tunnel client) - 192.168.0.5 
 
In this senario, 48050 (in the primary hub) is reserved for tunnel-proxy-port (for the  secondary hub).
This can be verified through hub GUI - [Hubs] tab - [Source] column for the secondary hub entry.
  
If port access of 48050 (in the primary hub) from ump robot is blocked, discovery wizard will show the error message.

After activating port access (from ump robot), the problem will be gone.
 
Additional Information:
Tech tip - Unable to acquire Version information error on UMP Discovery Wizard
https://communities.ca.com/docs/DOC-231180457-tech-tip-unable-to-acquire-version-information-error-on-ump-discovery-wizard