UIM 8.47 upgrade fails during the Upgrade Preparation phase

Document ID : KB000047278
Last Modified Date : 14/02/2018
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Issue/Problem/Symptoms: 

UIM 8.47 upgrade fails during the Upgrade Preparation phase with the following pop up error message:

"Failed to communicate with UIM server instance for upgrade. Re-insert administrator password and if error persists, an uninstall and re-install of the product is required."

 

Note: The C:\tmp\ca_uim\uimserver_ia_install.log captures the following entry:

DEBUG impl.UIMServerUpgradePreparationController:loginToNMS:670 [SwingWorker-pool-2-thread-2] - ENTER: loginToNMS
DEBUG impl.UIMServerUpgradePreparationController:loginToNMS:684 [SwingWorker-pool-2-thread-2] - Failed to log into UIMServer. Waiting and trying again.
INFO impl.UIMServerUpgradePreparationController:startUIMServer:414 [SwingWorker-pool-2-thread-2] - Unsuccessful communication with uimserver instance.
DEBUG impl.UIMServerUpgradePreparationController:startUIMServer:421 [SwingWorker-pool-2-thread-2] - Starting uimserver instance.
ERROR impl.UIMServerUpgradePreparationController:startUIMServer:439 [SwingWorker-pool-2-thread-2] - NimException caught.
(6) permission denied, Failed to log into UIMServer at host '10.130.246.*' after '5' attempts.

Environment:  

UIM 8.47 Upgrade

Cause: 

Installer is unable to communicate with the UIM primary server robot

Resolution/Workaround:

Changed the controller/robot IP setting on the UIM primary server from an IP entry with a wildcard to the actual IP address.

Example:
1.1.1.* to 1.1.1.2

Note: Primary Hub should be configured with a static IP address.

Exit and rerun the UIM 8.47 upgrade installer