UAPM 12.9 web service over HTTPS doesn't work.

Document ID : KB000008350
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Having gone through all of the steps in the documentation to enable SSL for UAPM 12.9, making the changes as per TEC1012932, and downloading the new WSDL, web services do not work. Trying to use them in SoapUI either gives a blank screen as the response, or an error:

HTTP/1.1 500 System.ServiceModel.ServiceActivationException

Looking in the Windows event logs, there is an additional error:

Log Name:      Application
Source:        System.ServiceModel 4.0.0.0
Date:          2017-10-03 11:49:28
Event ID:      3
Task Category: WebHost
Level:         Error
Keywords:      Classic
User:          NETWORK SERVICE
Computer:      vgas0634.vgregion.se
Description:
WebHost failed to process a request.
 Sender Information: System.ServiceModel.ServiceHostingEnvironment+HostingManager/37080511
 Exception: System.ServiceModel.ServiceActivationException: The service '/APIService/Gen/BAAAAAA/F/Service.svc' cannot be activated due to an exception during compilation.  The exception message is: The provided URI scheme 'http' is invalid; expected 'https'.
Parameter name: context.ListenUriBaseAddress. ---> System.ArgumentException: The provided URI scheme 'http' is invalid; expected 'https'.
Environment:
UAPM 12.9 configured to use SSL.
Resolution:

The documentation for enabling SSL says:

Configure IIS on the product servers to support the Secure Socket Layer (SSL) protocol.
Follow these steps:
1. Launch the Internet Information Services (IIS) Manager on the CA APM web server.
2. Select Server Certificates.
3. Click Create Self-Signed Certificate and specify a certificate name.
4. Select the web site (on the left) where CA APM is installed (for example, Default Web Site).
5. Click Bindings under Actions on the right. The Site Bindings dialog opens.
6. Click Add.
7. Select https for the Type.
8. Specify the port and the SSL certificate name.
9. Perform these same steps on the CA APM application server.

An additional step is required:

10. Select the web site (on the left) where CA APM is installed (for example, Default Web Site).
11. Click Bindings under Actions on the right. The Site Bindings dialog opens.
12. Select the HTTP:99 binding and remove it.

Once the HTTP binding is removed, web services over HTTPS will then work.