U0021707 Error compiling XREQ object: 'XEXECUTEOBJECT(ACT)', client: '00000'. Details next line.

Document ID : KB000089166
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
U0021707 Error compiling XREQ object: 'XEXECUTEOBJECT(ACT)', client: '00000'. Details next line.
Resolution:

Symptoms

After completing an update of your Automic system, when attempting to start your WP it fails with the following lines shown in the log file:

U0021707 Error compiling XREQ object: 'XEXECUTEOBJECT(ACT)', client: '00000'. Details next line.
U0021719 Syntax error in object 'XEXECUTEOBJECT(ACT)', line '00072'. 'U1001319 Too many parameters are defined for function 'X_EXECUTE'.'.


Cause

This is caused by a mismatch between the InitialData and the Automation Engine. In your log file, do a search for all instances of the word 'Version'. You should get results similar to:

U0003400 Automic Server 'UC4TEST#WP' version '9.00A220-241' started.
U0011849 UC4_sys_info: '@(#)UC4 Version    9.00A220-241\'
U0003621 Version of Automic database objects: '9.00A304-561'
U0003380 Server 'UC4TEST#WP' version '9.00A220-241' (Runtime '0/00:00:18', Log# '1', Trc# '1').
U0003410 UC4.Server 'UC4TEST#WP' version '9.00A220-241' ended abnormally.

The bolded lines illustrate the issue. The Automation Engine was not upgraded to the same version as the InitialData.


Resolution

After confirming the above, reinstall the component that has the mismatch that is not the version you are attempting to upgrade to (in the given example, the Automation Engine would need to be properly upgraded).