U0021178 This UCDBUP has step number 040. Current input file requires 050 or higher

Document ID : KB000088972
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
U0021178 This UCDBUP has step number 040. Current input file requires 050 or higher
Resolution:
Detailed Description and Symptoms

?I am running a DB Load of a Transport case from one version of 9.00A to another version of 9.00A and I get this error:

U0021178 This UCDBUP has step number 040. Current input file requires 050 or higher


Investigation

Service Pack 3 of 9.00A should be treated similar to a Major release rather than a simple hotfix release.  There are special notes regarding this release that you should be aware of.  This issue is one of those notes.

 

 

 

 

?There are Table changes between Service Packs that require the target system to be equal or higher than the sources system.

From the release notes in the documention:

 

 
For importing XMLfiles and loading Transport Cases, the affected UC4 system must have the same ServicePack version as the source or a later one. Any attempt to load an XML import file from an SP2 UC4 system to an SP1 UC4 system results in an error.

 
 
Modification Archive > Modifications in version 9.00 > Release Notes Version 9.00A > Service Packs


Solution

Upgrade the target system to 9.00A SP3 or find a version of the Transport case that was created before 9.00A SP3.