U0011605 The combination of hardware 'SAP' and software 'SAP' version '' ('000000001') is not suppor

Document ID : KB000089290
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
U0011605 The combination of hardware 'SAP' and software 'SAP' version '' ('000000001') is not suppor
Resolution:
Detailed Description and Symptoms
When attempting to start an SAP agent, the error message below occurs and the agent ends abnormally:

U0011605 The combination of hardware 'SAP' and software 'SAP' version '' ('000000001') is not supported.


Investigation
Check the agent's ini file to be sure that the [SAP_BASIS] section exists and that there is a Version= setting with the correct information.

Solution
The reason for this error is that the Automic system cannot find a software version for the SAP agent.  Usually an error like this would be fixed with an htyp table update, but in this case, it is fixed with the information below:

Under the [SAP_BASIS] section of the agent's ini file, be sure the correct information is in the Version= setting.  If this section and setting does not exist, add it just before the [VARAIBLES] section.  The following is an example of what this excerpt might look like:

[SAP_BCA]
Enabled=0
  
[SAP_BASIS]
Version=6.20
    
[VARIABLES]
; JCL-Variant for SAP_R/3
UC_HOST_JCL_VAR=SAP
; JCL-Variant for SAP_BW
;UC_HOST_JCL_VAR=SAPBW
UC_EX_PATH_BIN=./
UC_EX_PATH_TEMP=../temp/
UC_EX_PATH_JOBREPORT=../temp/