TSS0941I CERTIFICATE DATA SET NON-PKCS10 ERROR on the GENCERT command.

Document ID : KB000024475
Last Modified Date : 14/02/2018
Show Technical Document Details

Symptoms:

Certificates created in UNIX generate a .PEM format and will not be usable in Top Secret because the header and footer do not include the word 'NEW'. The word 'NEW' is necessary to identify the beginning and ending of the certificate.

The following errors will be received on the GENCERT command:

TSS0941I CERTIFICATE DATA SET NON-PKCS10 ERROR
TSS0301I GENCERT FUNCTION FAILED, RETURN CODE = 4

Resolution:

In UNIX you can use the parameter -newhdr when generating the certificate to include the necessary header and footer. Below is what the header and footer should look like:

BEGIN NEW CERTIFICATE REQUEST
END NEW CERTIFICATE REQUEST