Troubleshooting "Unable to load /opt/netegrity/webagent/bin/libmod_sm20.so into the server" error

Document ID : KB000053768
Last Modified Date : 14/02/2018
Show Technical Document Details

Description

There are various factors which will contribute to webagent start up errors with Apache. Please follow the following troubleshooting steps:

Solution

  • Verify that correct SiteMinder WebAgent Module is configured in the httpd.conf depending on the Apache version:

    1. Apache 2.0 requires libmod_sm20.so

    2. Apache 2.2 requires libmod_sm22.so

  • Verify that enviornment file 'nete_wa_env.sh' is sourced

    1. Is NETE_WA_ROOT, set correctly?

  • Are all required OS patches as mentioned in webagent documentation and release notes applied?

  • Check latest platform support matrix if webagent is supported on your specific webserver and OS: https://support.ca.com/irj/portal/anonymous/phpdocs?filePath=0/5262/5262_docindex.html#PSM

  • Does Apache user has read permission on SiteMinder webagent directories?

  • Start and stop Apache only by using apachectl.

  • If you are running 6QMR5 CR13 or older versions of webagent then make sure LLAWP is not running before Apache is started.

  • Make sure correct installer is used depending on32 bit or 64 bit WebServer.

  • Some OS Kernel setting needs to be tuned. Make sure that it has been done according to Web Agent Installation Guide > Operating System Tuning

  • If still failing then please provide CA_SiteMinder_Web_Agent_version_InstallLog.log, /opt/netegrity/install-info/nete-install-history.log and nete-wa-details.log when opening Support case, as well as webagent and webserver configuration files